zqifa的博客

我不管,反正我最萌~

公告

昵称:zqifa

站龄: 3年1个月

博客持续完善ing,敬请期待...

打滚求打赏(๑ ̄ ̫  ̄๑)

此处弱弱求打赏~~万一有好心人呢~~

支付宝酱

支付宝赞助

微信酱

微信赞助

随笔分类

php(94)

linux(62)

python(34)

web前端(32)

服务器(31)

js(28)

mysql(23)

docker(23)

html(22)

windows(22)

centos(21)

git(14)

前端设计(13)

算法(13)

字符编码(12)

django(12)

shell(10)

小游戏(10)

c++(9)

阅读(9)

更多

我的标签

php(90)

linux(45)

python(35)

js(27)

centos(27)

mysql(23)

docker(22)

windows(22)

web前端(16)

算法(15)

更多

相册

Package has no installation candidate解决方法

今天在安装软件的时候出现了Package has no installation candidate的问题,如:

# apt-get install <packagename>
Reading package lists... Done
Building dependency tree... Done
Package aptitude is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package <packagename> has no installation candidate

解决方法如下:

# apt-get update
# apt-get upgrade
# apt-get install <packagename>

这样就可以正常使用apt-get了~

作者:zqifa

出处:https://www.l1mn.com

原文地址:https://www.l1mn.com/p/c81jw2.html

本文版权归作者所有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接。

分类:linuxbug
标签:linuxbug

Copyright © zqifa 联系方式:z___qf@163.com